import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\s)*([a-z0-9]+)(\\s)*([a-zA-z0-9%,;()=\"'?\\.\\-:_\\[\\]&\\{\\}\\/\\s]*)(>|(\\s)*\\/>)*";
final String string = "<div class=\"portal\" role=\"navigation\" id='p-tb'>\n"
+ "<h3>Toolbox</h3>\n"
+ "<div class=\"body\">\n"
+ "<ul>\n"
+ "<li id=\"t-whatlinkshere\"><a href=\"/wiki/Special:WhatLinksHere/Human_trafficking_in_Canada\" title=\"List of all English Wikipedia pages containing links to this page [j]\" accesskey=\"j\">What links here</a></li>\n"
+ "<li id=\"t-recentchangeslinked\"><a href=\"/wiki/Special:RecentChangesLinked/Human_trafficking_in_Canada\" title=\"Recent changes in pages linked from this page [k]\" accesskey=\"k\">Related changes</a></li>\n"
+ "<li id=\"t-upload\"><a href=\"/wiki/Wikipedia:File_Upload_Wizard\" title=\"Upload files [u]\" accesskey=\"u\">Upload file</a></li>\n"
+ "<li id=\"t-specialpages\"><a href=\"/wiki/Special:SpecialPages\" title=\"A list of all special pages [q]\" accesskey=\"q\">Special pages</a></li>\n"
+ "<li id=\"t-permalink\"><a href=\"/w/index.php?title=Human_trafficking_in_Canada&oldid=560794473\" title=\"Permanent link to this revision of the page\">Permanent link</a></li>\n"
+ "<li id=\"t-info\"><a href=\"/w/index.php?title=Human_trafficking_in_Canada&action=info\">Page information</a></li>\n"
+ "<li id=\"t-cite\"><a href=\"/w/index.php?title=Special:Cite&page=Human_trafficking_in_Canada&id=560794473\" title=\"Information on how to cite this page\">Cite this page</a></li> </ul>\n"
+ "</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}