#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=card setlment).*(?=-)(.*)"
Local $sString = "" & @CRLF & _
" cb-lt " & @CRLF & _
" For 2020-12-08/12/3/3" & @CRLF & _
" dec tue " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Name ID shoping company shop gold Net Fees Net" & @CRLF & _
" card card card card " & @CRLF & _
"------------------------------------------------------------------------------------------------------------------------" & @CRLF & _
"smantha 5 78952 .00 366410.00 0.00 30800.00 -586.65 -471656.65" & @CRLF & _
"kamnthi 7 99999.00 0.00 0.00 0.00 0.00 -5800.00" & @CRLF & _
"nimali 8 8888888.00 587960.15 0.00 741985.00 -784.35 509027.80" & @CRLF & _
"" & @CRLF & _
"card setlment 4568153.37 2325802.00 3298.00 175882.41 -3049.24 -577589" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")