$re = '/(?<=card setlment).*(?=-)(.*)/m';
$str = '
cb-lt
For 2020-12-08/12/3/3
dec tue
Name ID shoping company shop gold Net Fees Net
card card card card
------------------------------------------------------------------------------------------------------------------------
smantha 5 78952 .00 366410.00 0.00 30800.00 -586.65 -471656.65
kamnthi 7 99999.00 0.00 0.00 0.00 0.00 -5800.00
nimali 8 8888888.00 587960.15 0.00 741985.00 -784.35 509027.80
card setlment 4568153.37 2325802.00 3298.00 175882.41 -3049.24 -577589
1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);