import re
regex = re.compile(r"(?<=class=[\"'][\w\- :\.]*)([\w\-:\.]+)", flags=re.MULTILINE)
test_str = ("<div class=\"px-4 sm:px-6 lg:px-8\">\n"
" <div class=\"sm:flex sm:items-center\">\n"
" <div class=\"sm:flex-auto\">\n"
" <h1 class=\"text-xl font-semibold text-gray-900\">Users</h1>\n"
" <p class=\"mt-2 text-sm text-gray-700\">A list of all the users in your account including their name, title, email and role.</p>\n"
" </div>\n"
" <div class=\"mt-4 sm:mt-0 sm:ml-16 sm:flex-none\">\n"
" <button type=\"button\" class=\"inline-flex items-center justify-center rounded-md border border-transparent bg-indigo-600 px-4 py-2 text-sm font-medium text-white shadow-sm hover:bg-indigo-700 focus:outline-none focus:ring-2 focus:ring-indigo-500 focus:ring-offset-2 sm:w-auto\">Add user</button>\n"
" </div>\n"
" </div>\n"
" <div class=\"mt-8 flex flex-col\">\n"
" <div class=\"-my-2 -mx-4 overflow-x-auto sm:-mx-6 lg:-mx-8\">\n"
" <div class=\"inline-block min-w-full py-2 align-middle\">\n"
" <div class=\"overflow-hidden shadow-sm ring-1 ring-black ring-opacity-5\">\n"
" <table class=\"min-w-full divide-y divide-gray-300\">\n"
" <thead class=\"bg-gray-50\">\n"
" <tr>\n"
" <th scope=\"col\" class=\"py-3.5 pl-4 pr-3 text-left text-sm font-semibold text-gray-900 sm:pl-6 lg:pl-8\">Name</th>\n"
" <th scope=\"col\" class=\"px-3 py-3.5 text-left text-sm font-semibold text-gray-900\">Title</th>\n"
" <th scope=\"col\" class=\"px-3 py-3.5 text-left text-sm font-semibold text-gray-900\">Email</th>\n"
" <th scope=\"col\" class=\"px-3 py-3.5 text-left text-sm font-semibold text-gray-900\">Role</th>\n"
" <th scope=\"col\" class=\"relative py-3.5 pl-3 pr-4 sm:pr-6 lg:pr-8\">\n"
" <span class=\"sr-only\">Edit</span>\n"
" </th>\n"
" </tr>\n"
" </thead>\n"
" <tbody class=\"divide-y divide-gray-200 bg-white\">\n"
" <tr>\n"
" <td class=\"whitespace-nowrap py-4 pl-4 pr-3 text-sm font-medium text-gray-900 sm:pl-6 lg:pl-8\">Lindsay Walton</td>\n"
" <td class=\"whitespace-nowrap px-3 py-4 text-sm text-gray-500\">Front-end Developer</td>\n"
" <td class=\"whitespace-nowrap px-3 py-4 text-sm text-gray-500\">lindsay.walton@example.com</td>\n"
" <td class=\"whitespace-nowrap px-3 py-4 text-sm text-gray-500\">Member</td>\n"
" <td class=\"relative whitespace-nowrap py-4 pl-3 pr-4 text-right text-sm font-medium sm:pr-6 lg:pr-8\">\n"
" <a href=\"#\" class=\"text-indigo-600 hover:text-indigo-900\">Edit<span class=\"sr-only\">, Lindsay Walton</span></a>\n"
" </td>\n"
" </tr>\n\n"
" <!-- More people... -->\n"
" </tbody>\n"
" </table>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
"</div>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)