using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[0-9]{4}-){3}[0-9]{4}|[0-9]{16}";
string input = @"5123-4567-8912-3456
61234-567-8912-3456
4123356789123456
5133-3367-8912-3456
6124-56378912-3456";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}