$re = '/(?:[0-9]{4}-){3}[0-9]{4}|[0-9]{16}/';
$str = '5123-4567-8912-3456
61234-567-8912-3456
4123356789123456
5133-3367-8912-3456
6124-56378912-3456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);