#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)User-Name=(?:host\/)?(?:[A-Za-z]{3}\\\\)?([a-zA-Z0-9\-\\\_.]+?)([.@][^.\n]+\.[^.\n]+)?$"
Local $sString = "Syslog Example 1: User-Name=user1.domain.com" & @CRLF & _
"" & @CRLF & _
"Syslog Example 2: User-Name=user1" & @CRLF & _
"" & @CRLF & _
"Syslog Example 3: User-Name=dmn\user1" & @CRLF & _
"" & @CRLF & _
"Syslog Example 4: User-Name=dmn\\user1" & @CRLF & _
"" & @CRLF & _
"Syslog Example 5: User-Name=user1@domain.com" & @CRLF & _
"" & @CRLF & _
"Syslog Example 6: User-Name=host/user1" & @CRLF & _
"" & @CRLF & _
"Syslog Example 1: User-Name=user.user.domain.com" & @CRLF & _
"" & @CRLF & _
"Syslog Example 1: User-Name=user.user"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")