# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"User-Name=(?:host\/)?(?:[A-Za-z]{3}\\\\)?([a-zA-Z0-9\-\\\_.]+?)([.@][^.\n]+\.[^.\n]+)?$"
test_str = ("Syslog Example 1: User-Name=user1.domain.com\n\n"
"Syslog Example 2: User-Name=user1\n\n"
"Syslog Example 3: User-Name=dmn\\user1\n\n"
"Syslog Example 4: User-Name=dmn\\\\user1\n\n"
"Syslog Example 5: User-Name=user1@domain.com\n\n"
"Syslog Example 6: User-Name=host/user1\n\n"
"Syslog Example 1: User-Name=user.user.domain.com\n\n"
"Syslog Example 1: User-Name=user.user")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.