#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^?#]+).*"
Local $sString = "https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share" & @CRLF & _
"https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA" & @CRLF & _
"https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe" & @CRLF & _
"https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs" & @CRLF & _
"https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry" & @CRLF & _
"https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze" & @CRLF & _
"https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")