import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^ +| +$)";
final String string = "SELECT Test1,\n"
+ " Test2, Test3 FROM Tabelle1 UNION \n"
+ " ALL SELECT * FROM Tabelle2 \n"
+ " UNION SELECT * FROM Tabelle3 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}