const regex = new RegExp('(^ +| +$)', 'gm')
const str = `SELECT Test1,
Test2, Test3 FROM Tabelle1 UNION
ALL SELECT * FROM Tabelle2
UNION SELECT * FROM Tabelle3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}