const regex = /^(?!^0(\.0|m|)$)([0-9]+)(\.[0-9]|m?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!^0(\\.0|m|)$)([0-9]+)(\\.[0-9]|m?)$', 'gm')
const str = `0.0
0
0m
0.1
1.1
10.1
1
20
1m
10m
100m
1000m
10000m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}