use strict;
my $str = '0.0
0
0m
0.1
1.1
10.1
1
20
1m
10m
100m
1000m
10000m';
my $regex = qr/^(?!^0(\.0|m|)$)([0-9]+)(\.[0-9]|m?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}