import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<action>[a-zA-Z]+)@\\/(?<dev_path>.*)\\/(?<subsystem>[a-zA-z]+)\\/(?<name>[a-zA-z]+)";
final String string = "change@/devices/soc/9000000.usb/power_supply/usb\n"
+ "change@/devices/soc/9000000.usb/power_supply/usb\n"
+ "change@/devices/virtual/android_usb/android0\n"
+ "change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
+ "change@/devices/soc/9000000.usb/power_supply/usb\n"
+ "change@/devices/soc/9000000.usb/power_supply/usb\n"
+ "change@/devices/soc/soc:usb_charger/power_supply/usb_charger\n"
+ "change@/devices/soc/soc:mains_charger/power_supply/mains_charger\n"
+ "change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
+ "change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
+ "change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
+ "change@/devices/soc/soc:usb_charger/power_supply/usb_charger\n"
+ "change@/devices/soc/soc:mains_charger/power_supply/mains_charger\n"
+ "change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}