# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<action>[a-zA-Z]+)@\/(?<dev_path>.*)\/(?<subsystem>[a-zA-z]+)\/(?<name>[a-zA-z]+)"
test_str = ("change@/devices/soc/9000000.usb/power_supply/usb\n"
"change@/devices/soc/9000000.usb/power_supply/usb\n"
"change@/devices/virtual/android_usb/android0\n"
"change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
"change@/devices/soc/9000000.usb/power_supply/usb\n"
"change@/devices/soc/9000000.usb/power_supply/usb\n"
"change@/devices/soc/soc:usb_charger/power_supply/usb_charger\n"
"change@/devices/soc/soc:mains_charger/power_supply/mains_charger\n"
"change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
"change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
"change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n"
"change@/devices/soc/soc:usb_charger/power_supply/usb_charger\n"
"change@/devices/soc/soc:mains_charger/power_supply/mains_charger\n"
"change@/devices/soc/99999999.i2c/i2c-3/3-0025/power_supply/battery\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.