package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b((\d|[1-9]\d|1\d{2}|2[0-4]\d|25[0-5])\.){3}(\d|[1-9]\d|1\d{2}|2[0-4]\d|25[0-5])\b`)
var str = `255.0.248.10
10.5.0.256`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}