re = /\b((\d|[1-9]\d|1\d{2}|2[0-4]\d|25[0-5])\.){3}(\d|[1-9]\d|1\d{2}|2[0-4]\d|25[0-5])\b/m
str = '255.0.248.10
10.5.0.256'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end