const regex = /(?<=\d{4})\d+(?=\d{4})/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d{4})\\d+(?=\\d{4})', 'mig')
const str = `1234 5678 12345678 12345678901234536
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}