$re = '/(?<=\d{4})\d+(?=\d{4})/mi';
$str = '1234 5678 12345678 12345678901234536
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);