import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'(.*?video\\.mp4)'";
final String string = "p.setup({\n"
+ " autostart: true,\n"
+ " file: 'http://test.com/d/wfne46sgmeikmgi3mg4kfmdgsunj4/video.mp4',\n"
+ " type: 'mp4',\n"
+ " height: window.innerHeight,\n"
+ " image: '//cdn.test.com/thumb/hjjjgef.jpg',\n\n"
+ " startparam: 'start',\n"
+ " width: window.innerWidth,\n"
+ " abouttext:'Player',\n"
+ " aboutlink: 'http://www.test.com/abc',\n"
+ " logo: {\n"
+ " hide: true,\n"
+ " file: '//cdn.test.com/images/logo.png'\n"
+ " },\n"
+ " sharing: {\n"
+ " code: encodeURI('<iframe width=\"640\" height=\"360\" src=\"http://test.com/embed-fwahrhsrh.html\" frameborder=\"0\" scrolling=\"no\" allowfullscreen></iframe>'),\n"
+ " link: 'http://www.test.com/fwahrhsrh'\n"
+ " },\n"
+ " });";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}