import Foundation
let pattern = #"'(.*?video\.mp4)'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
p.setup({
autostart: true,
file: 'http://test.com/d/wfne46sgmeikmgi3mg4kfmdgsunj4/video.mp4',
type: 'mp4',
height: window.innerHeight,
image: '//cdn.test.com/thumb/hjjjgef.jpg',
startparam: 'start',
width: window.innerWidth,
abouttext:'Player',
aboutlink: 'http://www.test.com/abc',
logo: {
hide: true,
file: '//cdn.test.com/images/logo.png'
},
sharing: {
code: encodeURI('<iframe width="640" height="360" src="http://test.com/embed-fwahrhsrh.html" frameborder="0" scrolling="no" allowfullscreen></iframe>'),
link: 'http://www.test.com/fwahrhsrh'
},
});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)