using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bAM19/0(?!803)[678]\d{2}\b";
string input = @"AM19/0601
AM19/0805
AM19/0803
AM19/0601,AM19/0602";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}