re = /\bAM19\/0(?!803)[678]\d{2}\b/m
str = 'AM19/0601
AM19/0805
AM19/0803
AM19/0601,AM19/0602'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end