import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "if\\s+(\\()?i\\*{2}2\\s*\\+\\s*j\\*{2}2\\s*==\\s*k\\*{2}2(?(1)\\)|)\\s*:";
final String string = "Sin paréntesis encaja:\n"
+ "if i**2+j**2==k**2:\n\n"
+ "Con paréntesis también:\n"
+ "if (i**2+j**2==k**2):\n\n"
+ "Con paréntesis no balanceados no encaja:\n"
+ "if i**2+j**2==k**2):\n"
+ "if (i**2+j**2==k**2:\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}