re = /if\s+(\()?i\*{2}2\s*\+\s*j\*{2}2\s*==\s*k\*{2}2(?(1)\)|)\s*:/m
str = 'Sin paréntesis encaja:
if i**2+j**2==k**2:
Con paréntesis también:
if (i**2+j**2==k**2):
Con paréntesis no balanceados no encaja:
if i**2+j**2==k**2):
if (i**2+j**2==k**2:
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end