package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((http|https):\/\/)?(www)?\.chytryhonza\.cz\/?([?=&]+.+)*$`)
var str = `www.chytryhonza.cz?utm_source=sorce&utm_content=hjha`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}