$re = '/^((http|https):\/\/)?(www)?\.chytryhonza\.cz\/?([?=&]+.+)*$/';
$str = 'www.chytryhonza.cz?utm_source=sorce&utm_content=hjha';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);