import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\-]*BEGIN\\sCERTIFICATE\\sREQUEST[\\-]+.+[-]+END\\sCERTIFICATE\\sREQUEST[-]+)";
final String string = "-----BEGIN CERTIFICATE REQUEST-----\n"
+ "MIIEuDCCAqACAQAwczELMAkGA1UEBhMCVVMxGDAWBgNVBAMMD3BsdWdpYmlsaXR5\n"
+ "LmNvbTEXMBUGA1UEBwwOU2FsdCBMYWtlIENpdHkxFDASBgNVBAoMC1BsdWdpYmls\n"
+ "aXR5MQ0wCwYDVQQIDARVdGFoMQwwCgYDVQQLDANPcmcwggIiMA0GCSqGSIb3DQEB\n"
+ "AQUAA4ICDwAwggIKAoICAQCfQqx8YexJ4HjGqIpywxvTOPDnqIaZicD3IQSUdAb5\n"
+ "5vcfAaD/0KBH/6Oa2NPlq4mYAw2octDiuklvkXIUgnn85vwlj6fLm6iR6i1tjM3g\n"
+ "tusxur3fmMdF9YqDNNM7LVSxXMq/vXuChPj3bVib2EyKJRcBn8EMTnJYdfl3YK4l\n"
+ "j+KW7cnxIy8E3DAy4KIUPbI2LNPix43emW6XuMB3hpvcbs2YpQogagAQwvNYAIcW\n"
+ "Ub3+fSEbXFNVmYFRPbd7T5Arei4Ubl8kKVWfqUnWIOdYQh7o0CbQl+67ivAyRnDU\n"
+ "oItNtPz+seWzL1xerjQqdlHrCQFGNfLdI3Hfl9SZVKOqdsjs2bEiP+C6E/pilvu/\n"
+ "zEtD5VbGd0UBBZtANm6BdBEhhigX8vL/FfiqxlPsEK31L9tQnwa6ETvcVbRQoXBW\n"
+ "idJJKCmiScz17ML8aTxw0zXc16CBHuE4AEV7xaNmdl5NsYCB+q/H3SCVsreMnu7A\n"
+ "cpCgvaCZX1/8zSWrVNMf0i+/gJCoBh1OXNnqtCPycJDPvrVGYF2U7RqzC4c91Kqe\n"
+ "QxEKHApEJAL47nFtM9c3K2fNvLEVOD+k+iDkEuL++VHaXO3VHCiVoJjQCSNTChl3\n"
+ "aSL29LadjcPvf2QdMymEJ4+wKI8u6l1bk51zN0INnVDDkMdtfCu0C8ux8M4roP9Y\n"
+ "kQIDAQABoAAwDQYJKoZIhvcNAQELBQADggIBAJO3HIp2hvkQh6/Bk19RiEdyfJjb\n"
+ "xoPWtfM4lWDyXLxq6HrmKadvOtjTs9fGpoBRJaknIhy8n0/oN8Et+uFgga3ptb/8\n"
+ "AjyDRVqmYK3byAJrUm055v9VseNwFqE/hsZiFtPMVA5I5agtnQm8o6zPgUSMQWso\n"
+ "evA00Fa+Q1X1Hmbthtd2ZH64cxLOqW3vW9LViBp9C52mU1NyZtvPRJAlcOlH1r9A\n"
+ "MFnPrR7T4HJ8gMEvaj0likFr5nQKWH5ScPvHbIKyIoebn9RznbMZBNjUn60+I0Kt\n"
+ "VwN8UrIwZMNF+eL99I6kEr/gjoZ3VegPH7YaVRQ280L4NvZNKMbAr1Z+uyCD587y\n"
+ "Zf+cbzZB30xTfra0/iUQnGEBuScpGQMdXEzmE/lBCnNnqnNohrAwvQNLISbnK7w2\n"
+ "JUrwbIIgRrLmmXGELPQ7vBkKmCtSrmPGLyWctwG005h8hHLtFk8jagSDJ/gTQ3Wv\n"
+ "n7YEy3ROHujz/UVGrGE2P3oKs5prn+N52HIxM9XoaQndrtbyvkaOe+WHGZ0htQkE\n"
+ "H6Rrh0YijAFpZTsKwv1ndMh2HpoaYX3B1s9ky3TWGAdOMCgHgdBFpvk2+PdDN+6a\n"
+ "Js+0VtfRywLxxaEamLciBj6JmjybIEBSANSwf2pdn8OnMq5BLZrLRWhsaMVGlciL\n"
+ "1JPHcsgLz1lD8FYC\n"
+ "-----END CERTIFICATE REQUEST-----\n\n"
+ "-----BEGIN PRIVATE KEY-----\n"
+ "MIIJQgIBADANBgkqhkiG9w0BAQEFAASCCSwwggkoAgEAAoICAQCfQqx8YexJ4HjG\n"
+ "qIpywxvTOPDnqIaZicD3IQSUdAb55vcfAaD/0KBH/6Oa2NPlq4mYAw2octDiuklv\n"
+ "kXIUgnn85vwlj6fLm6iR6i1tjM3gtusxur3fmMdF9YqDNNM7LVSxXMq/vXuChPj3\n"
+ "bVib2EyKJRcBn8EMTnJYdfl3YK4lj+KW7cnxIy8E3DAy4KIUPbI2LNPix43emW6X\n"
+ "uMB3hpvcbs2YpQogagAQwvNYAIcWUb3+fSEbXFNVmYFRPbd7T5Arei4Ubl8kKVWf\n"
+ "qUnWIOdYQh7o0CbQl+67ivAyRnDUoItNtPz+seWzL1xerjQqdlHrCQFGNfLdI3Hf\n"
+ "l9SZVKOqdsjs2bEiP+C6E/pilvu/zEtD5VbGd0UBBZtANm6BdBEhhigX8vL/Ffiq\n"
+ "xlPsEK31L9tQnwa6ETvcVbRQoXBWidJJKCmiScz17ML8aTxw0zXc16CBHuE4AEV7\n"
+ "xaNmdl5NsYCB+q/H3SCVsreMnu7AcpCgvaCZX1/8zSWrVNMf0i+/gJCoBh1OXNnq\n"
+ "tCPycJDPvrVGYF2U7RqzC4c91KqeQxEKHApEJAL47nFtM9c3K2fNvLEVOD+k+iDk\n"
+ "EuL++VHaXO3VHCiVoJjQCSNTChl3aSL29LadjcPvf2QdMymEJ4+wKI8u6l1bk51z\n"
+ "N0INnVDDkMdtfCu0C8ux8M4roP9YkQIDAQABAoICAGRnX2DnR1Vn/ByaQvaJBPDM\n"
+ "NCyINZt0mj/zA/UnlQJV1zQoDb1ZZMMfaqCD1Es2Mv+v5RtujzxxXzzEQFynyYpk\n"
+ "gVCY2Ztmngan0U4AeAcUqwBmD7B4nCEB5PpFAmqLcJqEupnZNpWZiXBL8pIF8nMh\n"
+ "YPi4I7fDeRlF/ymAvSmXJa4raaXpnYn92zEoJ2aFYuX+qvKNBmbw6iUi58wzA+4b\n"
+ "uOhkHBdFXJc0oL+5TXEHxbU8Y/Pg5/TOWxXBx/wos+aFF6nvz3F30bBfxNoHUnJ0\n"
+ "9RGnsODO+EYqGLZJbHbQZCJwWROlSgAGesCCKQcgIxL/UVtXRa6e2vqwuOqVzrv5\n"
+ "msBFM/HzcUvdtNq4FP2UfcqAi4FZlwHlbTDphE3fZSPbLIoJZLuhKuJPFA/Sc8L/\n"
+ "ABPnmRqb0bZ2RKECBnXrsV0U/KeSxbY4r0Hj+ggBnLNO1VhlYjCQZlCXA4X8LdyV\n"
+ "wBvoNeKjSo3ZD8vr/Jvpdm/9xiWVikbPqYpiEiIn6iN8omYWjxHWgDox9fd+zVQu\n"
+ "c/3giKEVAQYhNYj+YbkZpmnWQNjdL89TatjdBeaWO9Zq4k1VwN5UYB539O61kHfC\n"
+ "bhpYx/ptIgTBdEwp+ohlkAegCyBS+Mo3SiQocATdpeBwAMoMpMOtCiMDyGjydK0Y\n"
+ "2xi5+uOGMDKMbWvRe10FAoIBAQDMnaqknzt8Brc1KHQVv7Ww0VTrCEjItXLaAIOs\n"
+ "AW9PyL6/9lhFYljCnEGcWL3LAZlhldr81aNE40qw5FVVRrTR2Hg3xF/znZwa6Bnc\n"
+ "0t1XXGRj0BZIH5OrZSdf0gXdEwIrIB2LmllxMMpzd0BSgX/+x6k2K6FMAl/048bg\n"
+ "v986GsRwUjrlkt0ihyQNHlWuKKK82W1G6G4iQiC0bD5i/AUBer9o5Yb4X9GrgoIA\n"
+ "nWJIHstfJ80KTOJMQVczj0SKLmTjnIUE91BcXGhqTTdcSKTWbts50HyuwQAYcZco\n"
+ "vW5B5Sbyf57jCvu68Bo3gxngE1xYjtTR6Q13azII4DxyE7MjAoIBAQDHQTMNW8NQ\n"
+ "unvr64yqCwzBmEmpCJ6NEbYub3rqHzQPe5Na5VN1iTujKx5ifhi5uhR5A5Jluy2O\n"
+ "fUWzF/ihEdVOOh0JPj1NiJkY1VkuiY9Y2aHR2+8st06sp92Zj1i7Us/t+CP+WuOv\n"
+ "m7He4xRRrXx9tXcdpAzaTr8NoKXCL1fz4t8HKUZdfvvCtY+Ghd3ct1rEG8Bi9SUF\n"
+ "yBoTE1NwATHLCsYFURhpmWwnQTMpRTjlhogNSywDG59fdcqyEBUacCnPG7ZxZ3c2\n"
+ "N8VWknZsf9hBEyjyGCvTNq1A0KKJ6PIEp2gOoMi4I1nbKB1jSC7Gh61pJ+aV4L6g\n"
+ "M10Jh890RWq7AoIBAQC8vvv4G0Jd6Dv79zMOFOffEVpJ7DxnmKk3W54afsBVUpJS\n"
+ "tUU7y7qg2k7TkDCTIQiBsiBtdgzDsP7nKdllbnHB2PMcTjNMoCit0Uh6ILE4suuP\n"
+ "/xVutmIbipXFmBD8m1o2uctHSbwT47P8yxY0hWyycy8t3xVM7ivh1HNSQuwBx0tJ\n"
+ "aTEXMGB4Rz0ENOVIYAeuOMrKzAE77NAKXoc1+9AKS1Zhxsi4OHtKwHp3YraUXIOx\n"
+ "ZR+Izt85BFUSJKhO5vj91RYHPLOOX1eaJ1xX7lLP0za6oA1Djpkt8ypC1Grushk5\n"
+ "PGwud6U6Dd3BM1gdEP7wWeELOPXJIMLo2SApAu8NAoIBAGjYmPl9gJ/ZEN4KOyE6\n"
+ "4UJ5VME6RNusJzX1+TJ6qtU+zEH3C9x8EsKALOPcwDvye1VWGNGpFYa1ylg709tF\n"
+ "W/1mvOKhOnay2wRjNyMyxRgWpHyeAxN/fUmCpytnb2RaZgktGht8TfSYs5a53HZC\n"
+ "GJC5TO1u5kh1STjtgGtWqCwwA/VrtZf6+pTxHo3FoQHEBWHNzIUFw65wJbBF6hC0\n"
+ "wDO7/ojLrFHcpjldqIMd5pt4F90O4iDchxcfD0J1DfW0cXuGdJDlxafk3tT4CpJ7\n"
+ "Dxrm7xO8vkrMqYvCfNSem8LxJ+MSnauvBlg4moYkdGCJAimkEkRpV0VK4bjjGrlu\n"
+ "0YMCggEAGftF1dJBqkUKc9dsbSQYwwfaU+W/gFWU4otTPd89HIOVkKyz3Hc0FrEH\n"
+ "68Ffrlx1MZU8wbNjjXytujJ7vwn0+n0bXN+5/oqEM+zlVunefCCLWWVLD0Sc/yOx\n"
+ "llgrU9u2z8Zjjl+mbbWNKhjV6oBNw3qi4CNHiBMHQk98xGQaRaTh/t/laXxZgtIo\n"
+ "Y+mZN7OXk3IUv6xlO+OyneG+CU9/VOPszLK9yFf95m9l5R6E6v9r4eE9N5OMOTxT\n"
+ "SBXZ+zNnnF4bIjy747KtCVI7XJQURDBbhhXick/lgX6sNj87vMaDJDnZ9kqqgc3U\n"
+ "1H23mg7nAvcEhsYClM3Z8/bEH6eRBQ==\n"
+ "-----END PRIVATE KEY-----\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}