using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=No_23\"">).+?(?=;)";
string input = @";abcde;No_22"">123456;No_23"">;;No_24"">New York;No_25"">Qyt 4;>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}