$re = '/(?<=No_23\">).+?(?=;)/m';
$str = ';abcde;No_22">123456;No_23">;;No_24">New York;No_25">Qyt 4;>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);