package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\/(?:i|package)(?:\s*"([^\\]+\\\s*.*?)"|\s+([^\\"]+\\.*?)\s)`)
var str = `/i "package\name" test
/i "package\name" "test"
/i "package\ name" test
/i "package\ name" "test"
/I package\name test
/package package\name "test"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}