re = /:\s*([a-z\s-]*?)\s*year/m
str = 'history: four year-old boy was really sad when he found
out the toy was broken'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end