package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\(\*(?:[^(]|\([^*])*?\(?\*\)|\(\*[\s\S]*?\(\*[\s\S]*?\*\)[\s\S]*?\*\))`)
var str = `foo (* hello
(*
there
*)
*)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}