re = /(?:\(\*(?:[^(]|\([^*])*?\(?\*\)|\(\*[\s\S]*?\(\*[\s\S]*?\*\)[\s\S]*?\*\))/
str = 'foo (* hello
(*
there
*)
*)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end