import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)(?<label>([[:alpha:]]([[:alnum:]-]{0,61}[[:alnum:]])?)|\\*))(?=^.{1,255}$)(?:^(?P<name>(?P>label))\\.(?P<zone>(?:(?P>label)\\.?)*)$)";
final String string = "google.com\n"
+ "mail.google.com\n"
+ "test-.google.com\n"
+ "*.google.com\n"
+ "google.com.\n"
+ "101.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}