import re
regex = re.compile(r"(?(DEFINE)(?<label>([[:alpha:]]([[:alnum:]-]{0,61}[[:alnum:]])?)|\*))(?=^.{1,255}$)(?:^(?P<name>(?P>label))\.(?P<zone>(?:(?P>label)\.?)*)$)", flags=re.MULTILINE)
test_str = ("google.com\n"
"mail.google.com\n"
"test-.google.com\n"
"*.google.com\n"
"google.com.\n"
"101.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")