re = /(?>(\b(?:(?:[0-9]{7}|[0-9]{10,11})|[a-zA-Z][0-9]{10})\b)[^\r\n]*?(\b(?:\d{1,2}|(?:(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember|(?:t\.?|\.))?|Oct(?:ober|\.)?|Nov(?:ember|\.)?|Dec(?:ember|\.)?)))(?:[^A-Za-z0-9\v](?:\d{1,2})\,?[^A-Za-z0-9\v](?:\d{2}|\d{4})|[^A-Za-z0-9\v\.](?:(?:\'|\`)\d{2}|\d{4}))\b)[^\r\n]*?(\$\d+[\.\,\d]*)[^\r\n]*?($))|(?2)[^\r\n]*?(?:(?1)|(?3))[^\r\n]*?(?4)|(?1)[^\r\n]*?(?:(?2)|(?3))[^\r\n]*?(?4)|(?3)[^\r\n]*?(?:(?1)|(?2))[^\r\n]*?(?4)/m
str = '9991110022 9/4/2019 9/12/2019 $10403.33
10/2/2019 11/2/2019 33300011113 $130.30
12200013131 Nov. 2, 2019 $45,300.32
9991110022 9/4/2019 9/12/2019 $10403.33
$492,300 10/2/2019 11/2/2019 33300011113
5/3/2019 $500.30
12200013131 Nov. 2, 2019 $45,300.32'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end