$re = '/^.*?(?<! _)$/ms';
$str = 'This is d_ata 1
_This is _
data 2
This _is data 3a
This _
is _
data 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);