re = /^.*?(?<! _)$/m
str = 'This is d_ata 1
_This is _
data 2
This _is data 3a
This _
is _
data 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end