$re = '/^[A-Za-z]+(?:(?: +|, |-)[A-Za-z]+)*$/m';
$str = 'A
Az
A-z
A-z, By
RR-R, Com-pany I-nc
Латиница верхний нижний регистр ([A-Za-z])
Пробел, запятая, тире.
Строка начинается и заканчивается с литеры (любой).
Тире только между литерами.
Запятая только перед пробелом после литеры';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);