// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z]+(?:(?: +|, |-)[A-Za-z]+)*$").unwrap();
let string = "A
Az
A-z
A-z, By
RR-R, Com-pany I-nc
Латиница верхний нижний регистр ([A-Za-z])
Пробел, запятая, тире.
Строка начинается и заканчивается с литеры (любой).
Тире только между литерами.
Запятая только перед пробелом после литеры";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}