$re = '/(?<!\\\\)([$]+)([^$]*?)\\\\([^$]*?[^\\\\])\1/m';
$str = 'some \\\\ random text $ 5\\\\ 6$
some $5x^2 \\$ random text $$ 5 \\\\ 6$$';
$subst = "\1\2\\\\\\\\\3\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;