import Foundation
let pattern = #"(?<!\\)([$]+)([^$]*?)\\([^$]*?[^\\])\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
some \\ random text $ 5\\ 6$
some $5x^2 \$ random text $$ 5 \\ 6$$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2\\\\\\\\\3\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)