import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(.*(?:[ -\\/:-@[-`\\{-~À-ÿ].*){4}))^[À-ÿ -~]{8,30}$";
final String string = "AABBCCDD\n"
+ "OK -- Match\n\n"
+ "aabbccdd\n"
+ "OK -- Match\n\n"
+ "11111111\n"
+ "OK -- Match\n\n"
+ "A1A1b2b2\n"
+ "OK -- Match\n\n"
+ "A@~D1dIo\n"
+ "OK -- Match\n\n"
+ "AAB BCC0\n"
+ "OK -- Match (1 special, it's okay)\n\n"
+ "AABBCC@@\n"
+ "OK -- Match (2 specials, it's okay)\n\n"
+ "AABB C\n"
+ "OK -- Match (3 specials, it's okay)\n\n"
+ "A@~`ABBC\n"
+ "OK -- Match (3 specials, it's okay)\n\n"
+ "AABB\n"
+ "OK -- Should't match and didn't match (Less than 8 symbols)\n\n"
+ "AABBCCDDEEFFGGHHIIJJKKLLMMNNOOPP\n"
+ "OK -- Should't match and didn't match (More than 30 symbols)\n\n"
+ "AA@@@@BB\n"
+ "ERROR ! -- Shouldn't match (4 specials, it's forbidden)\n\n"
+ "AAB B\n"
+ "ERROR ! -- Shouldn't match (4 specials, it's forbidden)\n\n"
+ "AAB$@@@@\n"
+ "ERROR ! -- Shouldn't match (4 specials, it's forbidden)\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}