re = /(?!(.*(?:[ -\/:-@[-`{-~À-ÿ].*){4}))^[À-ÿ -~]{8,30}$/m
str = 'AABBCCDD
OK -- Match
aabbccdd
OK -- Match
11111111
OK -- Match
A1A1b2b2
OK -- Match
A@~D1dIo
OK -- Match
AAB BCC0
OK -- Match (1 special, it\'s okay)
AABBCC@@
OK -- Match (2 specials, it\'s okay)
AABB C
OK -- Match (3 specials, it\'s okay)
A@~`ABBC
OK -- Match (3 specials, it\'s okay)
AABB
OK -- Should\'t match and didn\'t match (Less than 8 symbols)
AABBCCDDEEFFGGHHIIJJKKLLMMNNOOPP
OK -- Should\'t match and didn\'t match (More than 30 symbols)
AA@@@@BB
ERROR ! -- Shouldn\'t match (4 specials, it\'s forbidden)
AAB B
ERROR ! -- Shouldn\'t match (4 specials, it\'s forbidden)
AAB$@@@@
ERROR ! -- Shouldn\'t match (4 specials, it\'s forbidden)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end