$re = '/(?<=Phrase A: ).*[\r\n]+\KPhrase A: /m';
$str = 'Phrase A: Words
Phrase A: Words
Phrase A: Words
Phrase B: Words
Phrase B: Words
Phrase A: Words
Phrase A: Words
Phrase B: Words
Phrase A: Words
Phrase A: Words
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);