#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)Hello(?=[!,.\s]|$)"
Local $sString = "If you test Hello, Hello!, Hello or Hello it returns true as expected." & @CRLF & _
"" & @CRLF & _
"If you test .Hello, aHello or Helloa it returns false as expected." & @CRLF & _
"" & @CRLF & _
"However I have two problems:" & @CRLF & _
"" & @CRLF & _
"It returns true if you pass it Hello:, Hello?, Hello) etc. which is not what I want, only !, , , . should be allowed." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")