import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+|#+|@+)(?!.*(?:[0-9]+|#+|@+))";
final String string = "image.0001\n"
+ "image###\n"
+ "###image###\n"
+ "image001\n"
+ "image_001\n"
+ "001\n"
+ "0001.image\n"
+ "001image\n"
+ "001_image\n"
+ "image\n"
+ "01_image01\n"
+ "03_image01\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}