$re = '/([0-9]+|#+|@+)(?!.*(?:[0-9]+|#+|@+))/m';
$str = 'image.0001
image###
###image###
image001
image_001
001
0001.image
001image
001_image
image
01_image01
03_image01
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);