package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[\s\S]*)?(?:(?:"([\s\S]+)")|(?:'([\s\S]+)'))(?:[\s\S]*)?(?:(?:"([\s\S]+)")|(?:'([\s\S]+)'))(?:[\s\S]+)?$`)
var str = `'Two' 'singles'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}